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INTRODUCTION 
The volume of data is growing dramatically and the structures of the databases that house that 
data are more complex than ever before. Companies are now looking to their data models to 
help them understand their data assets in new and intricate ways. Data models that might have 
once focused solely on understanding the structure of the database for application developers, 
are now being called on to solve fundamental business questions like, “what is the single 
definition of a customer?”. As companies look toward solving these business problems they 
need to take advantage of the high end features available in data modeling tools. When ERwin 
users look at things like metadata impact analysis and traceability, they realize it’s time to make 
a change. 

This paper discusses the how and why of making that change, and how upgrading to ER/Studio 
can be done in a way that preserves the intellectual capital of legacy data models, while 
minimizing the impact of the change. With the numerous next-generation features and benefits 
as compared to ERwin, hundreds of Embarcadero customers have found ER/Studio to be an 
extremely productive and cost-effective alternative.  

BENEFITS OF ER/STUDIO OVER ALLFUSION 

ERWIN DATA MODELER 
SUPERIOR MODEL FILE SYSTEM TECHNOLOGY 
ER/Studio allows users to create multiple, mutually independent physical models from one 
common logical model within the same .dm1 file; ERwin requires multiple files to achieve the 
same effect thus losing the traceability between the logical and physical artifacts. ER/Studio’s 
separate but integrated approach offers the user a complete, easy to understand solution for 
synchronizing and updating logical models, physical models and live databases without having 
to manage and synchronize many loose files. These features enable administrators to:  

• Support database applications existing on heterogeneous database platforms such Oracle 
and Microsoft while maintaining traceability to the original logical model. 

• Prototype applications on non-production systems such as Access and subsequently move 
them to a more robust RDBMS, such as Oracle, Sybase or Microsoft, without having to 
manage multiple files. 

• Maintain physical data models for test, development and production environments within a 
single environment. 

• Impact analysis and traceability provided via “Where Used” capabilities. 

SUPERIOR METADATA IMPACT ANALYSIS AND TRACEABILITY 
ER/Studio provides features for maintaining the traceability between the original logical model 
and multiple physical models.  Coupled with ER/Studio’s ability to maintain multiple models 
within the same file, impact analysis is far easier and more reliable than with ERwin.  In addition 
to reports, ER/Studio also provides a “Where Used” feature which includes the following 
capabilities: 



Migrating from CA AllFusionTM ERwin® Data Modeler to Embarcadero ER/Studio 

 

Embarcadero Technologies  - 2 - 

 

• “Where Used” identify where logical business entities are used in multiple physical models 
to assess usage, impact analysis and general data enterprise. 

• “Where used” also identifies logical entities that have been ‘denormalized’ in physical 
database designs. 

• “User-defined” mappings allow the modeler to map two disparate logical and physical 
models when a bottom-up approach is needed.  

 

An example of “Where Used” showing two physical tables with different names derived from a 
single logical entity is shown in Figure 1: 

 

Figure 1  Entity Editor 

SUPERIOR VISUAL DATA LINEAGE FEATURES 
Documenting data lineage between systems is more critical than ever as data models are 
leveraged for SOA implementations, data warehouse projects, CDI/MDM projects and other 
data integration purposes.  ER/Studio offers modelers visual data lineage functionality to 
visually represent how data is mapped between systems.  This allows modelers to drive 
source/target mappings from the model rather than managing them separately in, say, an Excel 
spreadsheet or Access database.  The data flow components are also integrated with 
ER/Studio’s Where Used technology to provide impact analysis of what entities/tables are 
involved in what data flow processes. 
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SUPERIOR DIAGRAM LAYOUT FEATURES 
A common challenge to data modelers is producing a readable diagram.  ER/Studio provides 
the industry’s most effect options for automatic layout of diagrams.  These options are 
particularly useful when reverse engineering from source that do not contain diagram 
information, such as .sql DDL files and database catalogues. 

Users can choose from the following general layout types: 

• Circular 
• Orthogonal 
• Tree 
• Hierarchical 
• Symmetric 
• Tree 
• Disconnect Elements 
 
Each of these layout types contains extensive options to ensure that the resulting diagram is 
readable and understandable. 

SUPERIOR DIAGRAM NAVIGATION 
ER/Studio is designed to dramatically increase user productivity through superior navigation of 
large, complex data models. This saves time when searching for deeply buried elements in a 
model.  ER/Studio provides a number of features to assist with the management of large 
models, such as: 

• Multiple levels of nested Submodels (i.e. Submodels of Submodels of Submodels…), 
allowing modelers to present simpler “subset” diagrams that focus on specific areas of 
interest.  

• Numerous navigational aids, including: 
- Interactive panning and zoom features in the main diagram window. 
- Relationship navigation enabling the user to move to the entity at the far end of a 

relationship; this feature automatically pans through the diagram if necessary.  
- An Overview Window enabling the user to pan through the diagram via a thumbnail 

view. 
- A Zoom Window to display items under the mouse cursor in a separate window at 

100% magnification. This is useful for examining detail of a complex diagram when 
the main diagram window is at a very low level of magnification, e.g. “zoomed out”. 

- A variety of significantly superior diagram object display options such as: 
 Displaying logical names alongside physical names if preferred 
 Displaying indexes bound to tables 
 Displaying “Attachments” (i.e. UDPs) on entities/tables 
 Displaying ‘code’ objects (procedures, materialized views, functions, etc) on 

the diagram display  
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SUPERIOR MODEL PUBLISHING AND COMMUNICATION 
ER/Studio Enterprise includes a web portal that allows for “near” real-time publication of the 
information contained in the ER/Studio repository (offered with the Enterprise Edition).  The 
portal allows developers, DBAs and business analysts to browse, search and report on the 
model metadata via a web browser.  It drastically streamlines the process of communicating the 
models by offering a “self-service” method for publishing the information.  The data architects 
no longer need to refresh reports any time a model changes.  The portal has a separate 
reporting repository that is optimized for searching and reporting that is kept in synch with the 
ER/Studio repository via an ETL process. 

SUPERIOR META MODEL AND PRODUCT EXTENSIBILITY 

META MODEL EXTENSIBILITY 
ER/Studio’s widely leveraged ‘Attachments’ system feature is designed to allow users to ‘attach’ 
new and unique metadata to any portion of a data model for user-specific needs. This helps to 
ensure the data model can be leveraged by an organization for a wider audience, allowing the 
data models to offer more than just ‘classic’ entity, attribute, datatype, and relationship 
information.  

Attachments allow organizations to include metadata that document anything from data 
governance policies, to data stewardship, to workflow information. ER/Studio also allows an 
architect to incorporate security classification schemes, map privacy policies to the data or 
document relevant compliance laws. 

PRODUCT EXTENSIBILITY THROUGH THE AUTOMATION INTERFACE USING VBA 
ER/Studio allows users to utilize built-in VB macros to gain programmatic access to the entire 
application ‘shell’.  Users can modify one of dozens of existing macros or build their own macros 
to extend the existing functionality to meet their specific business needs.  Examples of simple 
macros include exporting the model to an Excel spreadsheet, import reference values from 
Excel, data type converters, primary and foreign key constraint generator, and many others.   

SUPERIOR METADATA CAPABILITIES 
Both ER/Studio and ERwin offer dictionary systems which allow creation and access to reusable 
components such as domains, rules, valid values, etc.  However, the similarities end there. 
ER/Studio’s Data Dictionary system and Where Used interfaces ensure infinite levels of object 
traceability. 

THE DATA DICTIONARY IN ER/STUDIO PROVIDES MODELERS WITH THE FOLLOWING: 

• It is reusable and importable across disparate ER/Studio model files (without the need for a 
collaborative Repository).   

• It is recursive in that reusable objects can be used within other reusable objects (e.g. a 
Default can be created once, and then reused in many Domains). 

• It includes a much wider set of reusable objects (e.g. Attachments, Domains, Reference 
Values, Naming Standards Templates, Attachments, Defaults, Rules, Template Procedures 
and Triggers and more) than ERwin. 
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• It offers superior metadata traceability through Binding Information Interfaces found in the 
Data Dictionary and other key objects to quickly display where elements (e.g. Domains) have 
been bound in the diagram in order to assess the impact of change. 

 
With the Enterprise version of ER/Studio, the data dictionaries can be shared dynamically across 
any model in the repository allowing an architect to enforce standards enterprise wide.  
Changes to an enterprise dictionary object will propagate to any model leveraging that object. 

PLAN THE CONVERSION 
Planning lays the groundwork for the conversion project which helps avoid many potential 
pitfalls and landmines.  It also helps determine the time and effort needed for the process. 

PERFORM AN INVENTORY AND ASSESSMENT OF CURRENT 
MODELS 
The first step in converting to another modeling product is to understand the investment in the 
current modeling product.  This involves identifying and analyzing all the models that have been 
produced in ERwin. 

If ERwin’s model manager is being used, the inventory is easy.  The models should all reside in 
the model manager; however, you should verify that all of the models are in fact being kept in 
ERwin’s model manager. 

If they are not in the model manager, the process may be much more difficult.  It is necessary to 
identify all models in use throughout the organization.  In the best case, there will be only a few 
enterprise models that have grown over the years that need to be converted.  More likely, there 
will be many models distributed across the organization in various departments.  They may live 
on a developer’s or DBA’s personal computers, various network drives or even in someone’s 
email inbox.  The important thing is to create an inventory of the models that exist, where they 
are located, and who owns and maintains them. 

After completing the initial inventory, the next step is to determine which models are in use and 
the nature of their usage.  This will determine the time and resources needed in the conversion 
effort.  Many companies have hundreds of models throughout their organization.  Some of 
these may be under active development and change.  Some of them may be effectively 
complete and subject to no or little change.  Some of them may be antiquated and no longer in 
use.  Identifying the usage of models will determine which models require conversion and will 
help estimate the resources and time needed for conversion. 

Another point to consider is the nature of the models.  Some models may be application 
specific and very physically oriented. They arose to manage a specific database, generate DDL 
and make changes to the structure.  These typically have little or no “logical” information, and 
may not even have a logical model.  In this case, it may be less costly to use ER/Studio to 
reverse engineer the live database rather than convert the ERwin model.  Reverse engineering 
ensures that models exactly match the database structure they are meant to support. This 
removes the need to validate the model structure for accuracy after the conversion and avoids 
potentially losing information such as storage parameters, triggers, stored procedures and 
other physical objects, which may not migrate during the translation.  Further, these types of 
models are often not kept in synch with the database implementation. 
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Unfortunately, reverse engineering from the live database will only work for a small subset of 
models.  Mature data models contain much more information than is contained in the 
implemented database.  Logical information such as subject areas, business rules, business 
names and definitions cannot be reverse engineered from the database catalog.  This 
information is too vital to lose.  The target audiences of the models have grown outside the 
technical arena.  Many business analysts rely on the logical data models as roadmaps to guide 
them in producing reports instrumental to marketing campaigns, customer profiling and 
inventory analysis.  Note that with these types of models, the physical models should be 
compared and synched with the target databases to ensure that the physical models are current 
and correct prior to conversion to ER/Studio. 

DEFINE A CONVERSION PROCESS 
A process for converting ERwin files and models to ER/Studio should be defined.  Key decisions 
that will need to be made as part of this process include: 

• Which models are to be converted to ER/Studio? 
• When should the models be converted? 
• Should ERwin physical models be validated and synched prior to conversion?  Or should this 

process be applied to the resulting ER/Studio models? 
• Who will perform the conversion? 
• Who will be responsible for verifying the resulting conversion? 
• Who will be responsible for future maintenance of the ER/Studio models? 

KEY FACTORS TO CONSIDER INCLUDE: 
• Are the models stable and effectively complete?  Or are they still under active modification? 
• What type of databases, if any, are the models used to maintain?  Are the database(s) 

maintained via tools other than the modeling tools? 

CONVERSION PROCESS 
The conversion process is designed to help maintain investments in legacy models and model 
metadata managed in ERwin 3.5.2, 4.1.x or ERwin r7.x, and to ensure a seamless transition to 
ER/Studio.   

The process of converting from ERwin® to ER/Studio depends on the version of ERwin® in use.  
Converting from pre-4.x and pre-r7x versions of ERwin® is a simple task.  ER/Studio has a native 
ERX import which can be leveraged to directly import the model into ER/Studio, which 
maximizes the amount of information imported into ER/Studio. 

In version 4.0 and later, the ERX export is no longer available.  Fortunately, an add-on to 
ER/Studio is available to import and export metadata from a variety of sources.  This not only 
allows you to import models from ERwin 4.1.x or r7.x, but allows you to integrate your model 
metadata to a wide spectrum of other BI, ETL and metadata interchange formats.   

For a complete list please refer to the Embarcadero Technologies website 
(http://www.embarcadero.com/products/erstudio/MIRModelBridges.xml). 

http://www.embarcadero.com/products/erstudio/MIRModelBridges.xml
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CONVERTING FROM COMPUTER ASSOCIATES ERWIN 3.5.2 
Note:  Before beginning the import process, you need to use Erwin 3.5.2 and save the model as 
an ERX file by going to File > Save As… and selecting ERX from the file type drop down. 

ER/Studio lets you import ERX files from ERwin 3.5.2 directly.  To import an ERX file, perform the 
following: 

1. Launch ER/Studio. 

2. Go to File > New. 

3. Select the third option Import Model From: 

 

4. Select ERX file from the dropdown list 

5. Click the Import button 

6. Browse to the ERX file you want to import. 

7. Click Open.  ER/Studio imports the ERX file and creates a dm1 file with a logical and 
physical model. 

8. The file name defaults to the name of the ERX file.  Go to File > Save to save the model to 
your local drive or a network drive.   

9. You may also opt to insert the models into ER/Studio Repository if it is installed.  In this case 
go to Repository > Diagrams > Add...  ER/Studio launches a dialog to initialize some 
diagram information, such as author, diagram name, project etc.  
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CONVERTING FROM ALLFUSION ERWIN DATA MODELER 4.1.X 
AND R7.X 
ER/Studio can import metadata from ERwin 4.1.x .er1 or ERwin r7 .erwin files by leveraging its 
add-on module MetaWizard.  You must first save your .er1 or .erwin file in their XML format.  If 
you have ERwin installed on the same machine as ER/Studio, the bridge will do this for you by 
leveraging the ERwin API.   

Note: If you do not have ERwin on the same machine as ER/Studio, you need to save the .er1 
file as an .xml file prior to importing into ER/Studio. 

ERwin 4.1.x .er1 and r7 .erwin files are notorious for having corrupt data.  Before saving the file 
as an .xml file, you should run their diagnostic check on the .er1 file.   

Use Erwin to clean up the file, go to Tools > Diagnostics….  This cleans up the .er1/.erwin file 
before the import into ER/Studio.  Once the repair is complete, you can go to File > Save As… 
and select .xml as the file type.  If you intend to have the bridge convert the .er1 or .erwin file to 
.xml then just proceed to the conversion steps. 

Note:  You many need to contact Embarcadero Technologies for a trial license of MetaWizard.  
Import and Export Bridges are separately licensed.  Contact sales@embarcadero.com. 

To import an ERwin .xml/.er1/.erwin file, perform the following: 

1. Launch ER/Studio. 

2. Go to File > New. 

3. Select the last radio option, Import Model From:. 

4. Select External Metadata from the list.  This launches MetaWizard. 

 

mailto:sales@embarcadero.com
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5. Select CA AllFusion ERwin 4.x Data Modeler or CA AllFusion 7.x Data Modeler from the list. 

6. Browse to the ERwin .xml file that you previously saved or the .er1/.erwin file if you intend to 
have the bridge do the conversion. 

7. Click Next.  MetaWizard validates the XML file for any errors or inconsistencies. 

8. Click Finish.  ER/Studio imports the Logical and Physical model. 

 

 
 

9. The file name defaults to the name of the ERwin file name with an extension of .dm1 
(ER/Studio native file extension).  Go to File > Save to save the model to your local drive or 
a network drive.   

10. You may also opt to insert the models into ER/Studio Repository if it is installed.  In this case 
log into the repository and go to Repository > Diagrams > Add Diagram...  ER/Studio will 
launch a dialog to initialize some diagram information, such as author, diagram name, 
project, etc., shown in Figure 2. 
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Figure 2  Add Diagram in ER/Studio Repository 

VALIDATION OF CONVERSION PROCESS 
In addition to converting the basic model objects such as entities, attributes, table, columns, 
etc, ER/Studio translates the ERwin file to ensure that other critical data is preserved, such as: 

• ERwin Diagram Aesthetics (Layout, Color, Font, etc) 
• ERwin Subject Area Importation 
• ERwin UDP Importation 
• ERwin Domains, UDTs, Rules and Defaults 
• ERwin definitions and notes for model objects 
 

Some physical information may be lost in translating the .xml files from version 4.1.x or r7.x, such 
as:  

• ERwin triggers and procedure code  
• ERwin macros 
• Table storage parameters  
• Storage objects   
 
After the conversion is complete, comparing the ER/Studio model to the live database can 
recover much of this physical information.  The comparison will also help validate that the 
physical structure of the tables, columns and foreign keys migrated properly.   

Validating the logical metadata can be a little more complex.  ER/Studio offers a variety of 
Microsoft® Excel reports via its extensive automation interface.  Entity and attribute metadata, 
submodel usage of entities, domain usage and object definitions can be exported into lists for 
analysis.  These reports can also be compared to reports generated from ERwin to assist in the 
validation.   
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Embarcadero Technologies, Inc. is a leading provider of award-winning tools for application 
developers and database professionals so they can design systems right, build them faster and 
run them better, regardless of their platform or programming language. Ninety of the Fortune 
100 and an active community of more than three million users worldwide rely on Embarcadero 
products to increase productivity, reduce costs, simplify change management and compliance 
and accelerate innovation. The company’s flagship tools include: Embarcadero® Change 
Manager™, CodeGear™ RAD Studio, DBArtisan®, Delphi®, ER/Studio®, JBuilder® and Rapid 
SQL®. Founded in 1993, Embarcadero is headquartered in San Francisco, with offices located 
around the world. Embarcadero is online at www.embarcadero.com

http://www.embarcadero.com/
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